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Copyright 2003-2012 Heide Mansouri, Texas Tech University.  ALL RIGHTS 

RESERVED.  Members of Texas Tech University or Texas Tech Health Sciences Center may 

print and use this material for their personal use only.  No part of this material may be 

reproduced in any form without written permission from Heide Mansouri, the author. 
 

Credit: This document was mostly adapted from Adobe Acrobat X Classroom in a Book. 

 

Introduction  

 Adobe PDF (Portable Document Format) is a universal file format that can be viewed 

on any platform (Windows, Mac, etc.) with the free Adobe Reader, or any of the 

Acrobat family products. 

 You create a PDF file by converting other documents and resources to Portable 

Document Format (PDF).  

 Adobe Acrobat is a powerful tool with many uses, but it is not an authoring 

application - that is, not an application in which you design page layouts, write 

text, or create and place images on a blank page. Instead, it works in harmony with 

other applications and built-in operating system features to produce PDFs that you 

can then use for a variety of purposes.  

 The best method for creating a PDF depends on several things:  

o What is the source document (documents printed on paper, Word 

documents, InDesign files, digital images, or spreadsheets)?  

o If the document you want to convert is already open in its authoring 

application, then there are several ways to convert the file to PDF without 

opening Acrobat.   

o Similarly, if Acrobat is already running, then you don’t have to open the 

authoring application to convert a file to PDF.  

 This course is designed to help you learn simple techniques to create PDFs, work 

with multimedia, use commenting tools, create PDF forms, and more. 

mailto:heide.mansouri@ttu.edu
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Adobe Acrobat Family, if you are using Windows OS 

 Adobe Acrobat X Standard 

 Adobe Acrobat X Pro (not professional- just pro includes Adobe Live Cycle 

Designer ES2 program) 

 Adobe Acrobat X Suite (includes Adobe Acrobat  X Pro, Live Cycle Designer 

ES2, Adobe Photoshop CS5, Adobe Captivate 5, Adobe Presenter 7, Adobe Media 

Encoder CS5 programs) 

 

Adobe PDF Advantages 

 Adobe PDF preserves exact layout, fonts, and format ; regardless of the 

computer Operating System (Windows, Mac, etc.) 

 PDF can contain multiple languages. 

 PDF can be secured to prevent undesired changes or printing, or to limit access to 

confidential documents. 

Course Objectives 

After completing this ShortCourse, you should be able to: 

 Convert a file to PDF; 

 Combine and build a PDF Portfolio from multiple files; 

 Convert web pages to PDF; 

 Add headers, footers, watermarks, and backgrounds; 

 Use the Selection tool for quick re-purposing of content; 

 Create blank PDF pages to compose content directly in Acrobat X Pro; 

 Manage all your PDF files with the PDF Organizer ; and 

 Sign a PDF file. 
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Starting Adobe Acrobat X Pro 

Adobe has completely redesigned the Acrobat user interface. If you’ve used earlier versions, 

the new user interface may take a little getting used to. To start the program, choose Start 

-> Programs -> Adobe Acrobat X Pro.                                                                                                                                                                                                                                                                                                                                         

 

Exploring the work area 

 Click    and navigate to the Lesson_5_Newsletter.pdf  in SC folder, 

located in the ATLC labs at  My Computer\ShortCourse Materials\Graphics\Adobe 

Acrobat\Lesson_5_Newsletter.pdf  (or, File -> Open -> SC Materials -> Graphics -> 

Adobe Acrobat -> Lesson_5_Newsletter). 

 Double-click the file to open it.  Note: The Acrobat menu bar appears only when it is 

open as a standalone application.  When Acrobat is open within the browser, only the 

browser application menu appears at the top of the window.  

 This document is a six-page newsletter. 

 Click any of the menu names to see a menu of commands.  

 If you close the menu bar by choosing View -> Show/Hide -> Menu Bar, you 

won’t be able to access any menu commands to reopen it. To reopen the menu bar, 

press F9 (Windows).  

 The task pane buttons located on the right side of the window: Tools, Comment, 

and Share.  

 Click Tools. 
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Getting Help 

 Choose Help -> Adobe Acrobat  X Pro Help … (F1) 

 Click the Getting Started Tutorial (under Popular Resources), to learn more 

about Acrobat X Pro. 

 Close the Getting Started Page. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Browsing a PDF document 

 If you’re not on the first page of the document, enter 1 in the page number box on 

the Common Tools toolbar, and press Enter. 

 Choose View -> Zoom -> Fit Width or click the Scrolling Mode button on the 

Common Tools toolbar to resize your page to fit the width of your screen. 

 Select the Hand tool  , and hold down the mouse button. The pointer changes to 

a closed hand. 

 Drag the closed hand up and down in the window to move the page on the screen 
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(similar to moving a piece of paper around on a desktop). 

 Press Enter to display the next part of the page. You can press Enter repeatedly to 

view the document from start to finish in screen-sized sections. 

 Choose View -> Zoom -> Zoom To Page Level, or click the Fit One Full Page 

button          

 You can also use the scroll bar to navigate to a specific page. 

 

Move through a PDF, using one of the following: 

 Click the Previous Page  or Next Page   button on the toolbar. 

 Choose View -> Page Navigation -> [location]. 

 Choose View -> Page Navigation > Page, type the page number in the Go To 

Page dialog box and then click OK.  

 Press the Page Up and Page Down keys on the keyboard. 

 

Tools 

 The Tools pane organizes the Acrobat tools into task-related panels. 

 You can Customize the Quick Tools toolbar. 

 Click the Create button on the Quick Tools toolbar.  

 Move your pointer down to the lower-left corner of the document pane to reveal the 

size of this page.  

 The page size display disappears when you move the pointer away from the area.  

 Notice that the page size is a standard 8.5 –by-11 inches.  

 Click the Bookmarks button  in the navigation pane on the left side of the work 

area. 

 You can use the Bookmarks to jump directly to bookmark’s destination pages in the 

document, if the document has been bookmarked. 

 The navigation pane displays the default navigation panels, including the 

Bookmarks panel.  
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 To open additional navigation panels, choose View -> Show/Hide -> Navigation 

Panes -> [panel name]. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Quick Tools toolbar 

 By default, the Quick Tools toolbar includes the Create button that provides several 

commands for creating PDF files, output buttons, basic commenting tools, and 

common page-manipulation tools.  

 It also includes a button for customizing the Quick Tools toolbar. 
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Common Tools toolbar 

 The Common Tools toolbar includes page navigation buttons.   

 To see the name or description of a tool in either toolbar, hover the pointer over the 

tool. 

            

 

Selecting tools 

 The default tool in Acrobat is the Selection tool          

 To select a tool from a toolbar, click its button in the toolbar. A selected tool usually 

remains active until you select another tool. 

 Click the Zoom In button   in the Common Tools toolbar three times.  

Acrobat enlarges the view. Only part of the document appears in the application 

window. 

 Click the Hand tool  in the Common Tools toolbar. 

 The Hand tool lets you pan around the document. 

 With the Hand tool selected, drag the document across the application window to see 

a different portion of the image. 

Note: A black arrow to the right of a tool indicates that there is a menu associated with 

that tool. Click the arrow to reveal that menu.   

 

Tools Pane 

 Some menu commands in Acrobat 9 have moved to the Tools pane in Acrobat X. 

 To add all the panels to the Tools pane, click the 

options menu  under the Share pane and choose a deselected panel from the 

list.  
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Selecting tools in the Tools Pane 

 Click Tools -> Click Content in the Tools pane. 

 Select the Edit Document Text tool in the Edit Text & Objects area of the 

Content panel.  The pointer changes to an I-beam when you move it over text.  

Note: if this is the first time you have used the Edit Document Text tool, there may 

be a delay while Acrobat loads system fonts. 

 Select some text in your document to edit, and type a different text (don’t press the 

Enter key). 
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 Choose File -> Save As -> PDF 

 Name the file MyNewsLetter.pdf, and click Save. 

 

 

 

 

 

 

 

 

 

 

 

 

 

Panels in the Tools pane 

 By default, the Tools pane displays the most commonly used panels.  

 To add or remove panels from the pane, select the panels in the Tools pane menu.  

 Acrobat uses the current Tools pane configuration in all PDF documents you open 

until you change the configuration again.  

 Some of the tools, and some entire panels are available only in Acrobat Pro. 

 The Pages panel contains tools for manipulating pages and page design. 
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To use the Comment pane 

 In the Common Tools toolbar, click the arrow next to the zoom percentage, and 

choose Zoom To Page Level so that you can see the entire page. 

 Click Comment in the upper-right corner of the application window to open the 

Comment pane.  Comments in the document are displayed in the Comments List 

area of the pane. 

 Click Annotations to open the Annotations panel if it’s not already open. 

 Select the Sticky Note tool  

 Click anywhere on page 1 of this document. A sticky note icon appears, and a 

message box opens. Type: This is much better than the last version! 

 Click anywhere on the page to deselect your comment. Your comment appears in the 

Comments List. 

 Click Comment to close the Comment pane. 
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Customizing the Quick Tools toolbar 

 In the Quick Tools toolbar, click the Customize Quick Tools button          

o In the Customize Quick Tools dialog box; the right side displays the tools 

currently in the toolbar, and the left side lists the tools you can add. 

 From the list on the left, expand Content, and then select Edit Document Text. 

 Click the right-arrow button to copy the tool to the list on the right. 

 Click the up-arrow button multiple times to move the Edit Document Text tool to 

the top of the list, so that it will appear first in the Quick Tools toolbar. 

 Click OK to save your changes. 

Note: You can add and remove tools to the right of the Customize Quick Tools button in 

the Quick Tools toolbar, but you cannot move or remove anything to its left, such as the 

Save and Print buttons.   
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Navigating PDF documents 

 You can zoom in and out, move to different pages, show multiple pages at a time, 

view multiple documents at a time, and even split a document to view different areas 

of the same document at a time.  

o Choose View -> Zoom -> Fit Width 

o Choose View -> Zoom -> Zoom To. 

 In the Zoom To dialog box, scroll down to choose 125%, and click OK. 

 Many navigation tools are available in more than one place; you can use the method 

that best suits your workflow. 

 

Accessing specific pages 

 Choose View -> Page Navigation -> Page. 

 In the Go To Page dialog box, type 6, and click OK. 

 Choose View -> Page Navigation -> Previous Page. 

 The Previous Page and Next Page commands serve the same purpose as the 

Previous Page and Next Page buttons in the Common Tools toolbar. 

 In the navigation pane (on the left side of the application window), click the Page 

Thumbnails button        

 Acrobat displays thumbnails of all the pages in the document.  

 Select the thumbnail for page 3. 

 Select the Hand tool in the Common Tools toolbar. 

 Drag in the document window to see a different area of the page.  

Notice: that the highlighted area in the thumbnail moves accordingly. 

 

Inserting a blank page 

In Acrobat, a blank page makes it easy to create a transition page or a notes page. 

 In Acrobat, Navigate to the last page of your PDF. 

 Open the Tools pane, and then the Pages panel. 

 Select More Insert Options in the Insert Pages area of the Pages panel, and 
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choose Insert Blank Page. 

 In the Insert Pages dialog box, choose After from the Location: menu, and make 

sure page 6 is selected in the Page area of the dialog box. And then click OK. 

 Click the Next Page button on the Common Tools toolbar to display the blank page. 

 Open the Content panel in the Tools pane.  

 Select Add Or Edit Text Box. Acrobat opens the Typewriter toolbar. 

 Select the Typewriter tool in the toolbar. The pointer turns into an I-beam.  

 Click an insertion point at the top of the page, and change the font (Adobe 

Garamond Pro Bold).  

 Type some notes. Double click to select the typed text, and use options on the 

Typewriter toolbar to change text attributes, including font size and color. 

 Choose File -> Save to save the document, and then close the file. 
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About creating Adobe PDF files 

 You can convert a variety of file formats to Adobe PDF, preserving all the fonts, 

formatting, graphics, and color of the source file, regardless of the application 

and platform used to create it.  

 You can create PDFs from digital images, document files, websites, scanned 

paper documents, and clipboard content. 

 If the document you want to convert to PDF is open in its authoring application (for 

example, a spreadsheet is open in Excel), you can usually convert the file to PDF 

without opening Acrobat (File -> Save as Adobe PDF – in Office 2010) 

 You also need to consider PDF file size and quality (image resolution, for 

example).  

 

To Create Adobe PDF files 

 Use the Create commands in the Acrobat File menu to quickly convert a variety of 

file formats to Adobe PDF and open them in Acrobat.  

 You can combine converted files into a single PDF, compact PDF file, PDF 

Portfolio. 

 Use Acrobat PDFMaker from Microsoft Office for Windows. When you install 

Acrobat, Acrobat PDFMaker menu is added automatically to supported applications 

that are installed on the computer.  

 Click the Create PDF button on the Acrobat ribbon (Office 2007 or 2010) 

 Use the Convert to PDF command to download web pages and convert 

them to Adobe PDF 

 Convert email messages to Adobe PDF in Microsoft Outlook  

 

 

 

 



Acrobat X Pro ShortCourse Handout           8/3/2012 

Heide Mansouri 

Technology Support ShortCourses 

Texas Tech University 

19 

PDF creation methods  

 Most files: 

o Create menu within Acrobat, by choosing From File -> Create 

o Adobe PDF Printer within most application, in the Print dialog box. 

o Drag- and- drop On the desktop or in a folder (drag and drop the file icons 

into open Acrobat window). 

o Context Menu, on the desktop or in a folder by right-clicking. 

 Paper documents  

o Requires a scanner and a hard copy of the document.  

o Create menu within Acrobat, by choosing PDF From Scanner.  

 Web pages  

o Create menu within Acrobat, by choosing Create PDF From Web Page.  

o Using the Convert menu on a Web page. 

 

 

 

 

 

 

 

Creating PDF with PDFMaker (Windows) 

 When you install Adobe Acrobat X, the installer adds Acrobat PDFMaker buttons 

or menu commands to the following applications:  

o Autodesk AutoCAD  

o Microsoft Office (including Access, Excel, Outlook, PowerPoint, Publisher, 
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and Word)  

o Microsoft Internet Explorer  

o Microsoft Project  

o Microsoft Visio  

 After you specify conversion settings, the settings apply across PDFMaker, Acrobat, 

and Acrobat Distiller until you change them. 

 

 

 

 

 

Enhancing and Editing PDF Documents 

 A PDF file is like a snapshot of your original document.   

 You can perform minor editing, but for substantial revision of your document, it is 

easier to make changes to the source document, and then regenerate the PDF. 

 You can modify PDF documents by rearranging, cropping, deleting, or inserting 

pages; editing text or images; or adding multimedia files.  

 You can also repurpose content by copying it for other uses. 

 

Editing Text and Objects 

The Edit Document Text tool works best when editing only a few characters. For more 

extensive editing, make changes in the original document. 

 Choose Tools > Content > Edit Document Text. 

 Click in the text you want to edit. A bounding box outlines the selectable text. If a 

bounding box doesn’t appear, choose Tools > Recognize Text > In This File.  

 Select the text you want to edit: 
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o Choose Edit > Select All to select all the text in the bounding box. 

o Drag to select characters, spaces, words, or a line. 

 Edit the text by doing one of the following: 

o Type new text to replace the selected text. 

o Press Delete, or choose Edit > Delete to remove the text. 

o Choose Edit > Copy to copy the selected text. 

o Right-click the text and choose the appropriate option. 

 Click outside the selection to deselect it and start over. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



Acrobat X Pro ShortCourse Handout           8/3/2012 

Heide Mansouri 

Technology Support ShortCourses 

Texas Tech University 

22 

Create and add text to a new, blank PDF  

This process can be useful for creating relatively small PDFs of up to about a dozen pages.  

For longer, more complex, or heavily formatted new documents, it’s usually better to create 

the source document in an authoring application that offers more layout and formatting 

options, such as Adobe InDesign or various business software products.  

Note: The PDF Editor can make changes in text only with PDFs created from blank pages.  

 To add a blank page to a PDF created by another method, choose File -> Create 

PDF -> From Blank Page.  

 Begin typing the text you want to add to the blank page.  

 Add any formatting to the text by selecting it and selecting options on the New 

Document toolbar.  

 As needed, select other tools and options that you want to apply to the PDF.  

 Choose File -> Save, and select a name and location for the PDF file.  

Note: When the page is filled with text, the PDF Editor automatically adds a new 

blank page to the document. 

  Choose Document -> Resume Editing (to add more text and formatting as 

needed).  

 

Prevent changes in PDF Editor  

You can freeze the text you have added to PDFs created from a blank page. This prevents 

anyone from adding or changing the text. There is no Undo for this process.  

 Choose Document -> Prevent Further Edits.  

 In the message that appears, click Prevent Further Edits button to confirm your 

choice.  

 Or, click Keep Text Editable button, if you want to continue adding or editing text 

with the PDF Editor.  
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View PDFs in Read mode 

When you’re reading a document, you can hide all the toolbars and task panes to maximize 

the viewing area on your screen. 

The basic reading controls, such as page navigation and zoom, appear in a semi-

transparent floating toolbar near the bottom of the window.  

 To open Read mode, choose View -> Read Mode (Ctrl + H), or click the Read 

Mode button in the upper-right corner of the toolbar.  This will maximizes the screen 

space available to a document in Acrobat so you can read it more comfortably. 

 To restore the work area to its previous view, choose View -> Read Mode again. 

You can also click the close button in the floating toolbar. 

Note: Read mode is the default viewing mode when you open a PDF in a web browser. 
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To Search the PDF File 

 Choose Edit - > Find (Ctrl + F).  

 Type your search word (letter, for example). 

 Use the previous, next buttons. 

 Or - use the Edit -> Advanced Search (Ctrl + Shift + F). 

 Close the Find box. 

 

 

 

Adding Security 

 You can secure a PDF using any of the following security methods: 

o Add passwords and set security options to restrict opening, editing, and 

printing PDFs. 
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o Encrypt a document so that only a specified set of users has access to it. 

 When you open a document that has restricted access or some type of security 

applied to it, you’ll see a Security Settings button  in the navigation pane to the 

left of the document window. 

Combining different types of files 

You can combine all the documents for a specific project; such as the text documents, 

email, spreadsheets, AutoCAD drawings, PowerPoint presentations, etc. into a 

single PDF as sequential pages.  

  To combine files, choose File -> Create -> Combine Files into a single PDF … If 

a PDF is currently open, it appears in the list of included files. 

 In the upper-right corner of the Combine Files dialog box, make sure that Single 

PDF is selected. 

 From the Add Files menu, choose any of the following: 

o To add individual files, choose Add Files, and then select the files. 

o To add all the files in a folder, choose Add Folders, then select the folder.  

o To add files that you have combined into PDFs in other sessions, choose 

Reuse Files. Then select a previously created PDF from the left list, and from 

the right list, select the component documents. (If you have not used the 

Combine Files dialog box before, this option is not available.) 

o To add currently open PDFs, choose Add Open Files, then select the files. 
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About PDF Portfolio 

 You can avoid the hassles of multiple email attachments by quickly assembling a 

wide range of content types including, videos (to play within your PDF), web pages, 

AutoCAD drawings, or an entire folder into a PDF Portfolio.  

 To create a PDF Portfolio, choose File -> Create PDF Portfolio -> follow the steps.  

 You can work with The Portfolio component files using various elements, such as 

panes, toolbars, and windows. 

 Then you can email your PDF Portfolio, or share at a shared server.  Or, send it for 

Shared review (Comments -> Send for Shared Review, or Send for Email 

Review).    
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A. PDF Portfolio toolbar 

B. Card representing the component files 

C. Component files and folders in the mini-navigator  

D. Layout pane for customizing the appearance 

To learn more: http://www.adobe.com/products/acrobatpro.html?promoid=JQCRX  

 

 

 

 

http://www.adobe.com/products/acrobatpro.html?promoid=JQCRX
http://www.adobe.com/products/acrobatpro.html?promoid=JQCRX
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To Create a PDF Portfolio 

 File - > Create -> PDF Portfolio … 

 Choose Combine Files into a Single PDF.  The Combine Files dialog box appears.   

 At the top of the dialog box, click Add Files.   

 In the Add Files dialog box, select one or more files and click Add Files.  

 Set the order of the documents by dragging them or by using the Move Up and 

Move Down buttons.  

 Click Next to move to the next screen in the wizard.  

 Select PDF Portfolio.  

 Click Combine Files. The Save As dialog box appears.  

 From the Save in list, browse to the location where you want to save the file.  

 In the File name box, type a name.  

 Click Save. The new PDF Portfolio is saved to your hard drive as a PDF. The Portfolio 

window opens in Acrobat and displays your PDF Portfolio.  
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 Or- File - > Create -> PDF Portfolio … 

 Follow the Steps. 
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Digital signatures 

 A digital signature verifies your identity and may include a photo, an image of your 

handwritten signature, or other personal details that you choose.  

 When you sign a PDF, you indicate that you approve of its contents. 

 If you receive a signed PDF, status icons let you know if the signature is valid.  

 If a signature is questionable, you can verify it manually.  

 To sign a document, you must obtain a digital ID or, create a Self-Signed digital 

ID in Acrobat or Adobe Reader. 

 A digital ID is like an electronic driver’s license that verifies your identity and may 

include your name, e-mail address, a photo, an image of your handwritten signature, 

or other personal details that you choose.  

 

To Create a Self-Signed Digital ID 

 In Acrobat, choose Tools ->  Sign & Certify - > Security Settings … 

 Select Digital IDs - > Windows Digital IDs 

 Click the Add ID button  

 Select the option A New Digital ID I want to Create Now, and click Next. 

 Specify where to store the digital ID, and click Next. 

 Type a name, email address, and other personal information for your digital ID. 

When you certify or sign a document, the name appears in the Signatures panel and 

in the Signature field. 

 Choose an option from the Key Algorithm menu. The 2048-bit RSA option offers 

more security than 1024-bit RSA, but 1024-bit RSA is more universally compatible. 

 From the Use Digital ID For menu, choose whether you want to use the digital ID 

for signatures, data encryption, or both. 

 Type a password for the digital ID file. For each keystroke, the password strength 
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meter evaluates your password and indicates the password strength using color 

patterns. Reconfirm your password.  Important: Make a backup copy of your digital 

ID file.  
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To Create a Signature Appearance 

 Choose Edit -> Preferences -> Security.  

 Click New …, and type a title.  

 On the Identity tab, specify options as desired.  

Note: You can modify your digital signature appearance. For example, you can include your 

scanned signature 

 

To Sign a PDF Document 

 Complete your document edits before you sign it. Changes made to the document 

after it is signed can invalidate the signature. 

 Create a Self-Signed Digital ID, or sign a PDF without a Digital ID. 

 Drag your pointer to create a space for the signature. 

 Follow the onscreen prompts to finish signing the PDF. 

Adding Stamps to your PDF 

 You apply a stamp to a PDF in the same way you apply a rubber stamp to a paper 

document. The Stamp tool appears in the Annotations panel by default. 

o Show Stamps Palette 

o Dynamic 

o Sign Here 

o Standard Business 

o Favorites 

o Create Custom Stamp … 

o Manage Stamps … 

 To Open the Stamps palette 

o Choose Comment >Annotations> Stamps> Show Stamps Palette. 

 To apply a stamp 
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o Click the Stamp tool. The most recently used stamp is selected. 

o In the Stamps Palette, choose a category from the menu, and then select a 

stamp. 

o Click the document page where you want to place the stamp, or drag a 

rectangle to define the size and placement of the stamp. 

o If you haven’t provided a name in the Identity preferences, the Identity 

Setup dialog box prompts you to do so. 
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To Reduce PDF file size 

 Reducing the size of PDFs improves their performance particularly when they’re 

being accessed on the web. 

 Choose File -> Save AS …  

 Select Reduced Size PDF … 

 Follow the steps and make your selections. 

 Click Save. 

 

 

To Save a PDF 

 Choose File -> Save As -> PDF. 

 In Reader, choose File -> Save As -> PDF or File -> Save As -> Text. 

 To save a copy of a PDF Portfolio, choose File -> Save As -> PDF Portfolio. 

 If you are viewing a PDF in a web browser, use the Save A Copy button in the 

Acrobat toolbar to save the PDF. 
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Print a portion of a page 

 Choose Edit -> Take a snapshot.  

 Drag around the area you want to print.  Acrobat copies the selected area to the 

clipboard. 

 Choose File -> Print, and choose Selected Graphic option. 

 

Creating Interactive Forms LiveCycle Designer 

 Adobe LiveCycle Designer ES is a standalone application included with Adobe 

Acrobat Pro for Windows.  

 Use LiveCycle Designer ES when you want to extend the basic form capabilities in 

Acrobat.  

 For example, a LiveCycle Designer ES form can include fields that let you easily add 

graphics to a form, and you can create dynamic and interactive forms. 

 You must use LiveCycle Designer to edit any forms that were opened and saved in 

LiveCycle Designer, even if the form was originally created in Acrobat. 

Recommended Online Resources 

 ADOBE TV - Learn Adobe Acrobat, Photoshop, Premiere, Flash, Connect, Aftereffect, 

Illustrator, Encore, InDesign...etc. http://tv.adobe.com/  

 Acrobat training and tutorials at lynda.com from TTU Library’s Lynda.com (on 

TTU campus network only) http://library.ttu.edu/lynda  

 Adobe® Acrobat® X Classroom in a Book®: The official training workbook from 

Adobe Systems, available from Safari Books Online http://library.ttu.edu   

 Adobe Acrobat User Community Sample Portfolios 

http://acrobatusers.com/gallery/pdf-portfolio        

 

 

Please e-mail your questions, comments, or suggestions to heide.mansouri@ttu.edu. 

http://tv.adobe.com/
http://tv.adobe.com/
http://library.ttu.edu/lynda
http://library.ttu.edu/
http://acrobatusers.com/gallery/pdf-portfolio
mailto:heide.mansouri@ttu.edu

